docs: check the CLI version before linking a project to a workspace
Issue for this PR
Closes #1599
Type of change
- Bug fix
- New feature
- Refactor / code improvement
- Documentation
What does this PR do?
The "Using with Claude Code" guide gives the Node.js minimum but not the CLI one. Someone with an older install skips the install step and runs altimate-code link, which fails on 0.12.4 ("Workspaces are a pilot feature and are off") and doesn't exist in 0.11.x and older. 0.12.5 is the first release that links without the pilot flag (#1381, #1396).
- Plugin setup, step 1: run the install again to upgrade; linking needs 0.12.5 or later.
- Use an Altimate workspace from Claude Code: a new first step, "Check your version", before sign-in. It has
altimate-code --version, says to rerun the install if it's older, and giveswhich -a altimate-code(where altimate-codeon Windows) for when an older copy onPATHstill runs. The later steps are renumbered.
The in-app setup guides get the same step in a separate change.
How did you verify your code works?
Ran the guide's commands as written in a clean npm prefix: on 0.12.4, altimate-code link fails with the pilot message. npm install -g altimate-code upgrades to 0.12.8, --version and which -a show the new copy, and link opens the workspace picker.
Cost side effects
None.
Screenshots / recordings
Docs only.
š¤ Generated with Claude Code
https://claude.ai/code/session_011chv9Rmu7jQXokum1WNcs7
Summary by CodeRabbit
- Documentation
- Clarified that rerunning the plugin installation upgrades Altimate Code.
- Specified that workspace linking requires version 0.12.5 or later, and added steps to check the installed version and upgrade if needed.
- Added guidance for locating competing executables on
PATHwhen the version check still reports an older release. - Renumbered the sign-in, project-linking, workspace-status, and Claude-use steps.